how to use it in winform

Jun 10, 2012 at 12:55 AM

I want use QRCODE.NET to a app in windows ,but as i use C#,how to code to use the dll,is there somebody has simple example,thanks 

Coordinator
Jun 10, 2012 at 5:40 AM

Once you have create project using Visual studio, check under your solution explorer at top right side. Right click References => add reference => browse tab => find and select dll file and press OK button. 

Now you can use QrCode.Net's namespace under any C# file in that project. 

If you can not find control under toolbox, mouse over any item inside toolbox and right click, select choose toolbox items then under .Net framwork components use browse button to select dll file then tick QrCode control under that list. 

Hope that helps. 

Sep 13, 2012 at 4:51 AM

Detailed .NET WinForms QR Code control integration and creation.

Oct 30, 2012 at 3:15 AM

Once you have create project using Visual studio, check under your solution explorer at top right side. Right click References => add reference => browse tab => find and select dll file and press OK button. 

in the solution explorer at top right side.the result of Add Reference is have a yellow Exclamation mark on "Gma.QrCodeNet.Encoding" item and cant't to use.

 

If you can not find control under toolbox, mouse over any item inside toolbox and right click, select choose toolbox items then under .Net framwork components use browse button to select dll file then tick QrCode control under that list. 

"Gma.Net\Gma.QrCodeNet.Encoding.dll" is not a Microsoft.net Module

 

I use vs2008

 

thanks

Coordinator
Oct 30, 2012 at 5:53 AM

For first one, its most likely your .net framework. Official dll is build on .Net 4.0. If you are working on old framework, please download latest source file and compile on your own. 

Another thing is that, project is base on vs2010. You will have to download and install vs2010 express for easy compile, else you might have to use vs2008 and create a project, port all cs file to that project and compile. 

For toolbox, I'm not sure. I haven't work on vs 2008 for ages. That's something you might have to find out on your own.

Oct 30, 2012 at 8:41 AM

thanks very much!

i have already install vs2010 and .net framework4.0

and now every thing is well.....

Coordinator
Oct 30, 2012 at 5:29 PM

Most of code should be compatible with .net 3.5. You can compile under that if your project requires.